Follow

Step by step troubleshoot

Is the IIS service running?

  • Try calling http://localhost

Should return a default IIS welcome page.

If not - then the IIS is not installed or configured properly 

Basic permissions on the Webserver

  • Create a test.html file and add the text "hello" to the file - save file in "pronestor" (or pronestordisplay) folder on the iis
  • Try calling the file like http://localhost/pronestor/test.html

If it fails - then investigate that iuser and authenticated users has at least read permissions on the folder (NTFS)

  • Try removing windows authentication on the website
  • Try calling the file like http://localhost/pronestor/test.html

DNS issues

  • If the server repsonse correctly on "http://localhost/pronestor/test.html"
  • But fails on the IP or hostname ex. "http://ourservername/pronestor/test.html"

Issue with DNS server - should be solved by customer internal IT since we don't have access to this 

Web server responding with 500 or 400 error codes

Check or IIS Common errors here from help 

How to get info on issues from log files

If site fails please look for error in:

  • Check error on screen (localhost if possible)
  • Check error in elmah (elmah.axd)
  • Check error in log.txt
  • Check error in MS Event Viewer (application section)

If an error shows and you can't solve it yourself - ensure that all relevant data is available before involving a developer.

If error still exists but error doesn't show in log files - ensure that all relevant data is available before involving a developer.

 

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk